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EXPERIMENT 01 

 

Introduction to Web Development 
 

Objectives 

 
To develop a basic web site. 

Equipment /tool Used 

•   Computer with any version of windows installed 
 
Background 

Internet is a ‘Network of Networks’. 
On the Internet, a website is represented by a URL (uniform resource locator). World Wide Web 
(WWW), also abbreviated as the web, is a system of interlinked hypertext documents that may be 
viewed through a web browser. Web can be accessed through web browsers like Internet 
Explorer, Google Chrome and Mozilla Firefox etc. To understand how WWW works, it’s 
important to first define what hypertext documents are. 

Hypertext: 

“Hypertext most often refers to text on a computer that will lead the user to other, related  
information on demand. Hypertext allows a form of user interface, which overcomes some of the  
limitations of written text. Rather than remaining static like traditional text, hypertext makes  
possible  a  dynamic  organization  of  information  through  links  and  connections (called  
hyperlinks). Hypertext can be designed to perform various tasks; for instance, when a user  
"clicks" on it or "hovers" over it, a bubble with a word definition may appear, a web page on a  
related subject may load, a video clip may run, or an application may open.” [Wikipedia] 

HTML: 
 
HTML is a hypertext markup language that is used to describe the structure of a webpage using  
tags. A web browser, an application that understands HTML tags and displays web pages  
accordingly, utilizes the HTTP protocol to receive HTML pages from a web server (also called  
HTTP server). 
It is important to note that the display of an HTML page in a browser is not the same text that we 
see if we were to edit the HTML page in a text editor. This is because the HTML file itself 
contains many instructions/ tags that are not displayed in the browser. The function of these tags/ 
information is simply to enable a browser to display the HTML file. This should become clear as we 
go through the exercises. 
 

Let’s develop a basic website 
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Part I---Creating directory/ index.html and format.css files 
 

▪   In this part, we will create a directory in which we will save today’s lab work. We will  
 also learn how to create and save index.html and format.css files. 
▪    On the desktop, create a folder named ITCLab3 

[Hint: this can be done by right clicking on the desktop, and then choosing New and then  
Folder] 

▪    Create an index.html. 
▪    Open the Notepad application. [Start > Programs > Accessories > Notepad] 
▪    Save the empty file as index.html by clicking on the File menu of the Notepad. 

 
 

On the file menu, choose “Save As”. The “Save As” window will appear as shown below: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

In a similar manner, create the format.css file. [We will later see how this file is used] 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 3.1 Save As 
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Save the empty file as index.html on the Desktop.  [We will use the Desktop as HTML 
playground, and once the files have been finalized, then they will be transferred to the ITCLab2 
folder.] To save the file as index.html, index.html must be written as the file name with the “Save as 
type” set to All Files. 

•   Note: As explained the “Save as type” should be set to All Files, if the “Save as type”  
 field is set to Text Documents (*.txt) then the file would be saved as index.html.txt  
 and not as index.html. 

 
 
 
 
 
 
 
 
 
 
 
 

Figure: 3.2 Save As-All Files 

Part II--- HTML Basics 

 

1.  Writing the HTML basic tags 

Open the index.html file on the Desktop and enter the <html> and </html> tags on the file.  

Note that in HTML, tags often (but not always) follow the convention that there is an  
opening tag and a closing tag. The opening tag in our context is <html> and the closing tag is  

</html>. These tags are used to inform the browser that the text between these tags is  
formatted according to HTML guidelines. The <html> tags are displayed in the figure below. 

 
 
 
 
 
 
 
 
 
 
 
Figure: 3.3 Index.html 

 
 
•   In the figure above, we do not have any HTML code in between the <html> tags. We  
 will now start to code the HTML page. 

2.  Inserting the title of the web page 
We will, first of all, learn the <head> tag and the <title> tag. 
•   The head element (text between the head tags) contains general information, also  
 called metainformation, about a document. The title (text between the title tags) is not  
 part of the text of the document but is a property of the whole document. It may not 
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contain anchors, paragraph marks, or highlighting. The title may be used to identify 
the node in a history list, to label the window displaying the node, etc. 

•   We will name the title of our webpage as ITC lab 03. Note how the title text is  
 enclosed in the head tags and the title tags. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 3.4 Head and Title Tag 

Open the index.html file on the Desktop (modified as above) with Internet Explorer (this can be  
done by simply double clicking on the index.html file). You will find that the Internet Explorer  
displays “ITC Lab 03” as the title of the web page as configured in the figure above. The  
webpage is still empty as we have not added any text in the main page’s body yet (we will do  
that soon). 

For now, the index.html page should look like the following. 
 
 
 
 
 
 
 

Figure: 3.5 Head and Title Tag Display 
 
•   Copy the index.html into the ITCLab3 folder on Desktop and rename it as Title.html.  
 [Hint: a file can be renamed by selecting, right clicking, and choosing the rename  
 option.] 

3.  Inserting text in a HTML page 
•   We will now add text to the main body of the HTML page. This is done using the  
 <body> and </body> tags. The text contained between the <body> and </body> tags  
 is displayed by a browser unlike data that is contained between the <head></head>  
 tags. 
•   Add the text contained in the following figure in the index.html file on the Desktop.  
 Save the file when done. The index.html file on Desktop should like the following. 
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Figure: 3.6 Inserting Text 

•   After saving the index.html file on Desktop, open the file in a browser (by double  
 clicking on the file). If the index.html file is properly configured, the browser display  
 should be as follows. You will notice that all there is no line break, and all the text we  
 had put between the <body> tags is on one line. 
•   A browser has to be told by HTML tags where line breaks, new paragraphs, etc.  
 should occur. Since we have not used those tags yet, all the text is on one line as  
 shown in the figure below. 
•   Save the index.html file on the Desktop in the ITCLab3 folder as Allon1line.html. 

 
 
 
 
 
 
 
 
 
 
Figure: 3.7 Inserting Text Display 

4. Inserting a line-break 
•   We will now use the <br> HTML tag to introduce line breaks. This tag does not have  
 a corresponding close tag and is used for introducing line breaks. 
•   Open the index.html file on the Desktop and make the changes highlighted in the  
 following figure. 
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Figure: 3.8 Inserting Line Break 

 
 

•   After making the changes, save the index.html file and open it using a browser. The  
 browser should display the page with proper line breaks as shown in the figure below.  
 You will see that all the text is not on the same line any more. 

 
 
 
 
 
 
 
 
 
 
 
 

Figure: 3.9 Inserting Line Break Display 
 

•   If you see the browser display as above, save the index.html file on the Desktop to the  
 folder ITCLab3 as Linebreak.html. 

5. Insert a paragraph 
 
•   In the figure above, all the text is in a single paragraph (although separated by line  
 breaks). To start a new paragraph, the HTML tag <p> should be used. The tag <p> is  
 used to mark the start of a paragraph, and the end of paragraph is marked by </p>. 
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•   To observe how a paragraph is formatted in HTML, open the index.html file on the  
 Desktop. Make the changes highlighted in the following figure and then save the file. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 3.10 Inserting Paragraph 
 
•   Open the index.html file on the Desktop (modified with the changes highlighted  
 above) with a browser. You will see now that the web page is composed of two  
 paragraphs. The second paragraph also has line breaks within the paragraph. The  
 browser display should look like the following. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure: 3.11 Inserting Paragraph Display 
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•   If you see the browser display as above, save the index.html page on the Desktop to  
 the ITCLab3 folder and name it as Paragraph.html. 

6. Inserting headings 

In the index.html file on the Desktop, currently no text is highlighted as a heading. If certain 
text is to be a heading, the HTML tags <h1></h1>, <h2></h2>, <h3></h3>, <h4></h4> (and 
so on) may be used. The tag <h1> is used for bigger sized heading with the heading size 
decreasing for <h2> <h3> and so on. 
 

Open the index.html file on the Desktop and make the changes highlighted in the following 
figure. The first paragraph is highlighted using the <h1> tags. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 3.12 Inserting Headings 
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•   After making the changes in the index.html file on the Desktop as shown above, save  
 the file. Open the file now with a browser. The browser display should look like the  
 following. You will note that the first paragraph now highlighted as a heading with a  
 large sized font. 

 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 3.13 Inserting Headings Display 
 

7. Inserting a hyperlink 
 
We will now add a hyperlink on the index.html file. Open the index.html file on the Desktop and 
make the change highlighted in the following figure. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 3.14 Inserting Hyperlink 
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•   Save the file after making the change highlighted above. Open the file using a  
 browser. You should see that the browser display is similar to as shown below. You  
 will observe that a hyperlink to the specified URL is now added. Click on the URL  
 and note where the target of the hyperlink. 
•   If the browser display is similar to as shown above, save the index.html file on the  
 Desktop to the folder ITCLab3 as Hyperlink.html. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure: 3.15 Inserting Hyperlink Display 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 3.16 Links added 
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Figure: 3.17 Links added 

8. Making text italic, underlined, or bold 
 
We will now see how a text can be italicized, underlined, or made bold in HTML. The tags for 
these tasks are, respectively, <i></i>, <u></u> and <b></b>. 

 
•   Italicizing: To italicize a body of text, it must be enclosed in <i> </i> tags. To  
 demonstrate this, open the index.html file on the Desktop and make the changes  
 highlighted in the following figure. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure: 3.18 Inserting text italic, underline or bold 
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•   After making the changes shown above, save the file and then open in using a  
 browser. You will observe that the text between the <i> and </i> tags is italicized. If  
 the browser display is as shown below, save the index.html file in the ITClab2 folder  
 as ItalicsAndUnderline.html. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure: 3.19 Inserting text italic, underline or bold Display 

9. Inserting a table and an image 

To create a table, add <table> </table> tags. 

Add <tbody> </tbody> tags to create body of a table. 

To insert columns, add <td> </td> tags. 

To insert rows, add <tr> </tr> tags. 

To insert an image in an HTML page, <img> tag is used. 

We will now demonstrate how an image is added to an HTML page. Modify the index.html 
page on the Desktop to as shown below and save the file. 

 

•   The HTML page will include the file taimur.jpg as an image. For this to work,  
 taimur.jpg should be in the same folder as the index.html file. Download the  
 taimur.jpg file from the course website and place on the Desktop. With the image file  
 also on the Desktop, open 
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Figure: 3.20 Inserting table and image 

•   The index.html file using a browser. You should be able to see the image as part of the  
 web page displayed in the browser 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 3.21 Inserting table and image Display 
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EXPERIMENT 02 

 

Basics of Microsoft Office Word 

 

Objectives 
 
To become familiar with word processing and enable students to use the various tools in MS Word 
effectively to perform common word processing tasks quickly. 
 
Equipment /tool Used 

•   Computer with any version of windows installed 

•   MS Office (MS Word) 

 
Background 

 
Explore Window 

Following is the basic window which you get when you start word application. Let us understand 

various important parts of this window. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure: 4.1 Overview MS WORD 
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Backstage View 

 
The Backstage view has been introduced in Word 2010 and acts as the central place for 

managing your documents. The backstage view helps in creating new documents, saving and 

opening documents, printing and sharing documents, and so on. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 4.2 Backstage View 
 

Review Tab 
 
The easiest way to correct spelling mistakes is to right click any word that has a red wavy  
underline 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 4.3 Review Tab 
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To check more than one word at a time, you can bring up the Spelling and Grammar dialogue box. 
To see it, click on the Review tab at the top of Word. On the Review tab, locate the Proofing 

section. Then click Spelling & Grammar: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 4.4 Spelling and Grammar 

Word count provides the statistics that how many pages, lines and paragraphs etc. are in our  

document 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 4.5 Word Count 
 

Another way To know the current word count of a document, open the document and right click 

on the status bar at the bottom of the Word window. The context menu which comes up will 
have an entry named “Word Count” which will tell you the current word count. 
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Figure: 4.6 Alternate for Word Count 

Using “Language” tab one can change the language. 
 
To insert a comment first select the text then go to “New Comment” on “Comments” group in  
“Review” tab. Click on “New Comment” and a new comment will be inserted. You can also  
move to next or previous comments and can also delete the comments using this “comments”  
group. 

 
To insert a comment in a document, highlight the area of text where you want to comment on. 

Click the Review tab on the Ribbon then click New Comment 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure: 4.7 Comment 
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Tracking Group: 

 
With this feature of tracking, you can track and view all changes that are made to the document. 

1.  While in the document, On the Review tab, under the Tracking group, click Track  

 Changes. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 4.8 Track changes 

1. On the Review tab, in the Changes section, click the Next button to move to the next change. 

2. Click the Accept or Reject button to accept the change or reject the change and move to the 

next change. 

3. Keep going until you’ve responded to all the changes. 

In “Compare” group there is an option to compare two different documents. This option is 

usually used to find out the similarity between two different documents 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure: 4.9 Compare Documents 
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After browsing the paths for original and revised documents click” ok”. A new document will be 
opened that will highlight the changes present in the both documents. 
 
View Tab 
 
View tab is used to change the document views. Go through each view and observe the changes 
that each view brings. 
 
Quick Access Toolbar: 
 
With MS Word 2010 there is also Quick Access Toolbar which has a save, undo Repeat Typing  
button and Customize Quick Access drop down list. Within the list there are New, Open, Save,  

E-mail, Quick Print, Print Preview and Print, Spelling & Grammar, Undo, and Redo, Draw  
Table, Open Recent File icons. You can also choose to show the Quick Access Toolbar below  
the Ribbon by choosing Show below the Ribbon selection and you can also customize further  
with the More Commands button and make Microsoft Word 2010 suitable to your preferences  

and needs. In such a manner Quick Access Toolbar of MS Word lets you performance routine  
tasks much faster. The Microsoft Word 2010 Quick Access toolbar and its functionality are  
shown below 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure: 4.10 View Tab 

Tasks: 

Formatting Text 
A computer is a device that accepts information (in the form of digitalized data) and manipulates it 

for some result based on a program or sequence of instructions on how the data is to be  
processed. Complex computers also include the means for storing data (including the program, 

which is also a form of data) for some necessary duration. A program may be invariable and built 

into the computer (and called logic circuitry as it is on microprocessors) or different programs may 

be provided to the computer (loaded into its storage and then started by an administrator or user). 

Today's computers have both kinds of programming. 
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EXPERIMENT 03 

 

References and Mailing tabs of MS Office Word 
 

Objectives 

To become familiar with word processing and enable students to use the various tools in MS 

Word effectively to perform common word processing tasks quickly. 

Equipment /tool Used 

•   Computer with any version of windows installed 

•   MS Office (MS Word) 

Background 

Reference Tab 

This tab provides the quick way to create table of contents, update it, enter citations or 

references, choose any writing styles and footnotes etc. For generating the table of contents first 

selects the text from the document to appear in it. After selecting the text, make it a heading from 

“Styles” group in home tab. After making different headings, go to “Table of Contents” option in 

“Table of Contents” group of “Reference” tab and select any one format. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 5.1 Table of Contents 
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In “Footnotes” group there is an option to add footnotes and endnotes. Footnotes and endnotes 

are an easy way to add or provide the reader with supplementary information and that  

information will appear at the end of the page. 

To insert a footnote or endnote, navigate to Footnotes section. To insert a footnote, click the 

menu option with text as AB1Insert (Placeholder1) Footnote 
 
 
 
 
 
 
 
 
 
Figure: 5.2 Footnotes 

Similarly, to insert an endnote, click the Insert Endnote menu option. 
 
 
 
 
 
 
 
 
 
Figure: 5.3 Endnotes 

 
The keyboard shortcuts for inserting a Footnote are Alt + Ctrl + F for inserting an Endnote is 
Alt + Ctrl + D 

Similarly, citations and bibliography can be inserted from “Citations and Bibliography” group.  

The writing styles can also be changes from here as citations depend upon it. In technical writing  

we have many different styles of writing that can be select from this group of “Reference” tab. 
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Figure: 5.4 Create Source 

In “Captions” group, one can give captions to the figures and hence can create the table of 

figures in the same manner as table of content were created. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 5.5 Table of Figures 

Mailing Tab 

We can create, and print envelops and labels using this tab. “Start mail merge” are used to create  

a form letter which one uses for printing and sending purpose. We can select the recipient also. 
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Figure: 5.6 Mailing Tab 

Insert Tab 

Click the Insert tab and click Table button. This will display a simple grid shown below. When 

you move your mouse over the grid cells, it makes a table in the table which appears in the  

document. You can make your table having desired number of rows and columns 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 5.7 Insert Tab 

Click the square representing the lower-right corner of your table, which will create actual table in 

your document and word goes in table design mode giving lots of options to work with table as 

shown below. 
 
 
 
 
 
 
 
 
 
 
 

Figure: 5.8 Designs 

Following are the simple steps to “delete” an existing table from a word document. 
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Figure: 5.9 Layout 

Step (1): Click anywhere in the table you want to delete. 

Step (2): Click the Layout tab and click Delete Table option under the Delete Table Button to 

delete complete table from the document along with its content. 

Following are the simple steps to “add formula” in a table cell available in word document.  

Step (1): Consider the following table where we will have total of the rows. Click in a cell that 

should contain the sum of rows. 
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Figure: 5.10 Formula Button 

Following are the simple steps to “add an existing picture” in your word document. It is 

assumed that you already have a picture available on your PC before you add this picture in your 

word document. 

Step (1): Click in your document where you want to add a picture. 

Step (2): Click the Insert tab and then click Picture option available in illustrations group, 
which will display Insert Picture dialog box. 
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Figure: 5.11 Insert Picture Dialogue Box 

Similarly, you can insert Clip Art, Shapes, and Charts etc. 
 
 

Task 

 
 

1.  Create the following structure in MS Word 
 
 
 
 
 
 
 
 
 
Solution 
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EXPERIMENT 04 

 

Fundamentals of MS Office PowerPoint 
 

Objectives 

•   To become familiar with the basics of making presentations using MS PowerPoint 

•   To become familiar with the basics of good presentation design 
 
Equipment /tool Used 

•   Computer with any version of windows installed 

•   MS Office (MS Power Point) 

 
Background 

Microsoft Power Point 

Microsoft PowerPoint is a software product used to perform computer-based presentations. 

There are various circumstances in which a presentation is made: teaching a class, introducing a 

product to sell, explaining an organizational structure, etc. 
 
Home Tab 

To begin Microsoft PowerPoint, go to Start Menu > All Programs > Microsoft Office > 

Microsoft PowerPoint 2010. Select PowerPoint Presentation from the Project Gallery if a blank 

document does not open. 

The Design Ribbon toolbar contains several categories for formatting the design and elements of 
your presentation. These include: Home, Insert, Design, Transitions, Animations, Slide Show, 
Review and View. The brief introduction of these tabs is; 

 

•   The Home bar: This has features that allow you to edit Slides, Fonts, Paragraph, Drawing  

 and Editing. 

•   The Insert bar: This has features that allow you to add Tables, Images, Illustrations,  

 Links, WordArt, and Media Clips. 

•   The Design bar: This allows you to edit how your presentation will look. It includes  

 features such as Page Setup, Themes, and Background Styles. 

•   The Transitions bar: This allows you to edit Slide Transitions, Effects, and Transition  

 Timing. The Animations bar: This allows you to add custom animations to your  

 presentation.  You  can  select  from  Preview,  Animations,  Advance  Animation,  and  

 Animation timing. 

•   The Slide Show bar: This has features that allow you to select how your presentation will  

 be displayed. From here, you can start your Slide Show, Set Up your Slide Show, and  

 Adjust Monitor Settings. 

•   The Review bar: This allows you to Proofread, Translate Languages, Comment Slides,  
 and Compare your Presentation. 

 

91 
 



 
 
 
 
 

•   The View bar: This has features that allow you to set the View of your Presentation,  
 Create Master Views, Show/Hide Features, Zoom, Switch from Color to Grayscale,  
 Adjust Windows, and Add Macros. 

 
Creating a new slide 

1. To create a new slide where you can add content, click the Home tab and select New Slide. 

2. Clicking the bottom half of New Slide will give you different new slide options. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure: 6.1 New Slide 

Slide types or layouts include - 

•   title slides 

•   title and content slides 

•   comparison slides 

•   two content 

•   picture with caption slides 

•   and more 
 
These layouts of slides will define the appearance of the slide and the way one can put data into 

the slides. The layout of the slides can also be change after they are inserted. In Slides group, 
there is a drop-down menu named as “Layout”. By clicking on layout tab and selecting a layout 

style, the style of current slide can be changed. 
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Figure: 6.2 Layout 

In this tab there is option to cut copy and paste the text. These options are available in 
“clipboard” group of Home Tab. Shortcut keys for copy, cut and paste commands are Ctrl+c, 
Ctrl+x and Ctrl+v respectively. 

Font group allows you to change the font of the text, size, and case etc. of the text. Select the text 

first then perform any operation. 
 
 
 
 
 
 

Figure: 6.3 Fonts 

In order to change the case of text, select the text you want to change then go to Font group of 

Home Tab and choose an option from drop down list. 

The simplest way to change the way your text looks is to use Bold, Italics, Underline 
button on the formatting tool bar. To apply these, just click the button you want your text to be 

formatted into. Formatting text involves Underline, Bold, Italic, and Text in different Fonts, Text in 

different font sizes, and text in different colors. 
 
Similarly, you can change the text color, outline and appearance etc. 

You can make the lists by using bullets, numbering and multilevel list in the “Paragraph Group”. 

1. Select the paragraphs you want to format 

2. Click the Home tab on the Ribbon and click the Bullets or Numbering button in the 

paragraph group 

Click the list arrow on each button to apply a different style of bullets or numbering 
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Figure: 6.4 Bullets 

Multileveled lists apply different bullets or numbering to the different levels of a list. 

1. Select the paragraphs you want to format 

2. Click the Home tab on the Ribbon and click the list arrow on the Multilevel List button in the 
paragraph group 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 6.5 Styles of Bullets 

1. Select the style you want to use 

2. Change the level of the items in the list by using the Tab key to increase the indent, and by 

pressing Shift + Tab keys to decrease the indent 
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Similarly, text indentation is also done using this “Paragraph” group. 
 
 
 
 
 

Figure: 6.6 Paragraph 
 

Line and Paragraph Spacing 

1. On the home tab of the ribbon, look for the paragraph group. Then click on the Line Spacing 

button, as shown in the image below. 
 
 
 
 
 
 

Figure: 6.7 Line and Paragraph Spacing 

Select your desired line spacing. From this menu you can select to have your line spacing set to 1, 

1.15, 1.5, 2, 2.5 or 3. 
 
 
 
 
 
 
 
 
 
 
 
 
Figure: 6.8 Line and Paragraph Spacing 

Text direction can also be changed. 
 
•   Select the test whose direction is to be changed 

•   Go to Home tab then in Paragraph group 

•   Select Text Direction and choose one option from the listed options 
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Figure: 6.9 Text Direction 
 
After selecting from Text Direction, the text’s direction will be changed on slide.  
To change the alignment of text within the text box, follow the following steps; 

•   Select the text. Go to Home tab then in “Paragraph” group. 

•   Click on “Align Text” option. Select any one option. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 6.10 Align Text 

Simple plain text can be converted into SmartArt. 
 
•   Select the text. Go to “Home” tab. 

•   Go to “Paragraph” group and select the “convert to SmartArt” option. 

•   PowerPoint will list different types of SmartArt graphics. 

•   You can convert your SmartArt graphic back to text by right-clicking the graphic or  

 SmartArt shape and selecting Convert to Text. 

•   You will lose some text customizations, such as changes to the text color or font size that  

 you made to the text on the slide when you convert the text to a SmartArt graphic. 
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•   After you select a layout for a SmartArt graphic, the text in your slides is automatically  
 put in shapes and arranged based on the layout that you chose. You can then customize  
 the SmartArt graphic by changing its color or by adding a SmartArt style to it. 

 
You can change the colors applied to the shapes in your SmartArt graphic. The different color 

combinations are all derived from the theme colors of your presentation. 
1. Click the SmartArt graphic. 

2. Under SmartArt Tools, on the Design tab, in the SmartArt Styles group, click Change  

Colors. 
 
 
 
 
 
 
 
 
 
Figure: 6.11 Smart Art Styles 

If you don't see the SmartArt Tools or Design tabs, make sure that you've selected a SmartArt  

graphic. You may have to double-click the SmartArt graphic to select it and open the Design tab. 

3. Click the color variation that you want. 

 
The figure shown below states the conversion of the text into SmartArt. It shows how the plain 

bulleted text is converted into a professional design. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 6.12 Smart Art Designs 
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“Drawing” Group of home tab is used to create different type of shapes like square etc. 
 
 
 
 
 
 

Figure: 6.13 Drawing 

Shape outline, color and effects can be changed using the same group in Home Tab. 

Find Replace option in editing group: 

1. On the “Home” tab of the Ribbon, go to the “Editing” group, and select “Find” … or use the 

shortcut key CTRL+F. 

2. Type the word you want to find, and then press enter. 

 
If you want to make a change to a specific word, you want to use the replace functionality. To 

replace a word/s in PowerPoint: 

1. Go to the “Editing” group, and select “Replace”, or use the shortcut key CTRL+H 

2. In the “Find what” text box, type the word you want to find 

3. In the “Replace with” text box, type the word that you want to replace the original word with 

4. To replace words one at a time, click “Replace”, if you want to replace every occurrence of the 

word in the document, click “Replace All” 
 
 
 
 
 
 
Figure: 6.14 Editing 

 

Insert Tab 

 
First group in insert tab is “Tables”. On selecting the “table”, different option will appear from 

where rows and columns can be selected. 

•   Click on the arrow underneath Table. This will open up a new box with several options  

 for creating a table. 

•   If you select the Insert Table option, a dialog box will appear where you can enter more  
 exact specifications for the table. 
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Figure: 6.15 Insert Table 

 

Next group is “Images” group. Any picture placed in any directory of the computer can be 
accessed using “Picture” option of this group and can be inserted in slides. Similarly Clipart can 
also be inserted using this group. 

 
 
 
 
 
 
 
 

Figure: 6.16 Insert Images 

It has an option of getting Screenshots. PowerPoint will automatically take the screenshots of 

already opened windows and gives the option to select the screenshot and insert in slide. 

To create a photo album 

•   Go to “Images” group of “Insert” tab. 

Click on the. It will give an option to create a new album or edit the existing one. 

•   On clicking the new photo album, the dialogue box is opened 
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Figure: 6.17 Photo Album 

On selecting multiple files for album, a new presentation will be generated having all those 

selected pictures. 

Shapes, SmartArt and charts can be inserted using the “Illustrations” group of the “Insert” tab. 

Adding Audio / Video to PowerPoint presentation: 

 
1. Click on the Insert tab of the ribbon. 

2. Click on the Movie or sound button in the media clip group to insert video or audio in 

Presentation. 

3. There are different options available for inserting audio or video to PowerPoint slides. 

4. If you want to hide the audio file during slide show, select “Automatically” from Play sound 
drop down menu and check the Hide during show option in the sound options group 

 
 
 
 
 
 
 
 
 
 
 
 
Figure: 6.18 Video from file 
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Adding Hyperlink: 

Select the text or image to link to insert a hyperlink. From right-click menu, click Hyperlink  

option 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 6.19 Hyperlink 

This will bring up Insert Hyperlink dialog, from left side bar, select place in This Document, from 

center pane, select a slide to create link with and click OK. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 6.20 Insert Hyperlink 

This will insert a hyperlink in a specified slide. 

Using “Text” group of “Insert” tab we can insert different text boxes, slide number and word art  

etc. 
 
 
 
 
 
 
Figure: 6.21 Insert Tab 
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EXPERIMENT 05 

 

Introduction to MS Office Excel 
 

Objectives 

MS Excel is spreadsheet software in the Microsoft Office Suite. Excel allows you to store 

manipulate and analyze data in organized workbooks for home and business tasks 

Equipment /tool Used 

•   Computer with any version of windows installed 

•   MS Office (MS Excel) 

Background 

Microsoft Excel is a spreadsheet developed by Microsoft for Windows, macOS, Android and iOS. 
It features calculation, graphing tools, pivot tables, and a macro programming language called 
Visual Basic for Applications. It has been a very widely applied spreadsheet for these platforms, 
especially since version 5 in 1993, and it has replaced Lotus 1-2-3 as the industry standard for 
spreadsheets. Excel forms part of Microsoft Office. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 7.1 Overview 

To begin, open Excel 2016 

Creating New Blank Workbook 

a.  At the top-left of your screen, you will see a File Button. Click on that Button and select new 

b.  Select ‘Blank Workbook’ from the window that appears, and click create 

c.  A new Excel workbook opens 
 
 

110 
 



 
 
 
 
 
 
 

Opening an Existing Workbook 

a.  Go to the File Button menu and click on ‘Open’ 

b.  A window appears with some path set (typically ‘My Documents’). The left-hand side of  
 the window shows some links that allow you to browse through different folders and  
 change the path 

c.  Go to the folder where the workbook you want to open is located, select the workbook  

 and click open 

A. Inside Home tab 
a.  In the Home tab you will see different sections ‘Clipboard’, ‘Font’, ‘Alignment’,  
 ‘Number’, ‘Styles’, ‘Cells’ and ‘Editing’. 
b.  Each section has different buttons. When you place mouse pointer over a button for two  
 seconds, a description of the button appears. Try placing the pointer over different  
 buttons and read the description of each button. 

I.  Exploring the Fonts Section 
a. Make the text bold by selecting some text and clicking on ‘B’. 
b. Italicize the text by selecting some text and clicking on ‘I’ 
c. Similarly, you can underline by clicking ‘U’, add border to cell. Change the font -type or 

the font-size. You can change the color of the text or highlight the text. 
d. Inside the Font section, click on the little arrow in the bottom right to explore more  

options. 

II. Exploring Alignment section 

a.  Text Alignment 

▪    You can left align text 
▪    You can right align text 

▪    You can center align you text  

▪    You can top align text  

▪    You can middle align text  

▪    You can bottom align you text 
b.  You can change text orientation, wrap text and merge & center multiple cells as well 

 
III. Exploring Alignment section 

Explore the use of 

‘Increase indent’ button.  

‘Decrease indent’ button 

IV. Creating New Sheet 

You can create multiple sheets within a single workbook 
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Figure: 7.2 Sheet 
 

B. Page Layout Section 

•   This tab is majorly used to set the margins, orientation and background of the  
 spread sheet. 
•   There is an option “Print Area” in page setup group. By using this option we can  
 select the area for printing purpose 

C. Formula Section 
•   We can apply different formulas using this tab. Function library group is one of the  
 mostly used groups 

 
 
 
 
 
 
 
 
 
 
 
 

Figure: 7.3 Toolbox 

Use of Basic Statistics 
You can use most common statistical metrics. 

•   Mean → Average () 
•   Sum of points / no. of points 
•   E.g. you have points, 4, 5, 6 then mean = (4+5+6)/3 = 5 
• =Average () 

•   Min/Max → minimum or maximum 
•   Max (4, 5, 6) = 6 
•   Min (4, 5, 6) = 4 

•   Standard Deviation → How wide-spread the data is. 
•   Bigger the spread, higher the standard deviation. 
•   Size of dataset also effects value of standard deviation. 

If we only have a few numbers ranging between 1 and 10 for example, the standard deviation  
will likely be higher than if we have thousands of numbers ranging between 1 and 10. For  
example, 
Both these sets A and B have an average of 5. But A has a standard deviation of 0.7 while B has  
a standard deviation of 4.1. Excel has a simple function to calculate the standard deviation of a  
set of points: 

=stdev () 
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Insert a linked Excel chart in PowerPoint 
You can insert and link a chart from an Excel workbook into your PowerPoint presentation.  
When you edit the data in the spreadsheet, the chart on the PowerPoint slide can be easily  
updated. 

1.  To chart your data in a worksheet 
a)  Make this table in Excel worksheet 

 
 
 
 
 
 

Figure: 7.4 Excel worksheet 

b)  Select the data that you want to chart 
 
 
 
 
 
 
 

Figure: 7.5 Excel worksheet 
 
 
c)   On the Insert tab, in the Charts group, click the chart type that you want to use, and then  
 click a chart subtype. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure: 7.6 Chart 

 

To insert a linked Excel chart in PowerPoint 
a)  Open the Excel workbook that has the chart that you want. 

Notes: 
•   The workbook must be saved before the chart data can be linked in the PowerPoint  
 file. 
•   If you move the Excel file to another folder, the link between the chart in the  
 PowerPoint presentation and the data in the Excel spreadsheet breaks. 
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b)  Select the chart. 
c)  On the Home tab, in the Clipboard group, click Copy 
d)  Open the PowerPoint presentation that you want and select the slide that you want to  
 insert the chart into. 
e)  On the Home tab, in the Clipboard group, click the arrow below Paste, and then do one of  
 the following: 

a.  If you want the chart to keep its look and appearance from the Excel file,  
 select Keep Source Formatting & Link Data 
b.  If you want the chart to use the look and appearance of the PowerPoint  
 presentation, select Use Destination Theme & Link Data 

f)  You can edit chart data in PowerPoint or in Excel by pressing Right Click->Edit Data 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 7.7 Charts in PowerPoint 

Copying chart as a picture from Excel sheet 
•   Use the option of Special Paste. 

CHART TITLE 

Projected Actual 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
QTR1 QTR2 

Figure: 7.8 Charts in PowerPoint Special Paste 
 

Tasks: 
 
1)  Sinusoidal Curves: Generate and plot a 101 sampled sine and a cosine wave of 5 Hz  
 frequency as shown below 

• 

• 
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•   where = 5 Hz 

• ranges from 0 to 1 in step of 0.01 
 
 
 
 
 
 
 
 
 
 
 
 

Figure: 7.9 
 
Solution 
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